Sonarqube is not ignoring a path it should

Hi, I have looked at the documentation at SonarQube and have added some paths for Sonarqube to ignore and it mostly all works, except for one path, and I can’t understand why.

An exclusion path like this works:


But this one does not work:


I’m still getting an issue raised on


The only difference I can really see is that first exclusion path excludes an entire module where the second one is just trying to exclude one directory/package in a module. Would there be any issue with that?

Any assistance you can provide would be greatly appreciated.

Hey there.

What version of SonarQube are you using? It should be noted in the footer of your instance.

Hi Colin,

  • Developer Edition
  • Version 9.2.2 (build 50622)


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

9.2.2 → 9.9.1 → 10.1 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your issue persists after upgrade, please come back to us!

Hi Colin,

Ok, I will look into the upgrade option.

Do you happen to know if this will likely fix the issue, was there a known bug on this?

We’re pretty big sticklers for only supporting non-EOL versions in this Community, otherwise users may never see the need to upgrade (and benefit from significant improvements in features, better logging, stability).

As mentioned, your issue persists after upgrade, please come back to us!