SonarQube Github Integration not working: Failed to check permissions with github, check the configuration

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    Community Edition Version 8.9 (build 43852)

  • what are you trying to achieve
    Integrate SonarQube with Github Enterprise for our organization

  • what have you tried so far to achieve this
    Referring to the instructions provided on this page followed the instructions under section Importing your GitHub repositories to SonarQube However SonarQube displayed the following error:

Failed to check permissions with Github, check the configuration


  1. What should be the GitHub API URL? I have provided, where orgname is replaced with the name of our Organization in smallcase. We tried hitting the URL from the browser and it provides the following output {"error":404,"message":"Not found"}, which I suppose means the URL is working.
  2. I have set the exact same permissions on the Git Hub app as documented in Step 1: Creating your GitHub App. Hence unsure why Failed to check permissions with Github, check the configuration error is occurring.

Do let me know if we need to check any additional settings.

Kind Regards,