SonarQube doesn't start with an error message about Eleasticsearch

Hi. I have successfully upgraded our SonarQube server (it’s deployed with DevOps on a Microsoft Azure app service) in the version, but when I try to apply the update, the SonarQube serveur don’t want to start with the following error message about elasticSearch : LIBFFI_TMPDIR environment variable was not specified

That’s the files deployed :

Any ideas about the problem please?

Hello @Yannick_DENIMAL ,

It seems like you are modifying Elasticsearch running script. Could you try to run with vanilla Elasticsearch script? Also could you explain why do you need to alter SQ’s script?

What’s the “vanilla Elasticsearch script” ?

With the version it’s good, but with the version it’s broken :

It seems like you have modified the script provided in SQ package (that is why I called it vanilla).

This environment variable is set in the code here.

Could you try to start SQ without any modification of that script and see if it helped?

If not you could consider setting this env variable in your script and point it to a temporary directory.

I fixed the issue. I’ve added the environment variable “LIBFFI_TMPDIR” to the azure service and it works now


I’ve added a ticket to our backlog to fix this issue.

I can reproduce it on my machine too.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.