SonarQube doesn't start and throws "The write format 1 is smaller than the supported format 2" error

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)

  • how is SonarQube deployed: zip, Docker, Helm

  • what are you trying to achieve
    start SQ

  • what have you tried so far to achieve this
    Tried the lts tag, but the error is the same. The setup was working fine for several months, I don’t know why it even tries to run this DB, Postgres credentials are passed to the container with envs.

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!
Caused by: org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.1.214/5]

Hey there.

What information are you providing when you start up the docker container (for example: where you’re defining the JDBC URL information). Please share the full command/file. A full stacktrace would be useful as well (a wider range of logs).

Thanks for your interest but I managed to solve the issue in the meantime. We were using “latest” image tag and the container wasn’t restarted for quite some time. Because of that at some point the envs got deprecated so Sonar wasn’t aware of the external DB.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.