SonarQube Developer Edition not picking up PostgreSQL Database instead it is picking up H2 database

Hello Team,

We have deployed the SonarQube Developer Edition on AWS ECS Fargate. We have downloaded docker image(SONARQUBE_VERSION=9.9.3.79811) from Docker hub. Pushed into the ECR repo and created the task definition by using launch type fargate.

We want to use PostgreSQL db to store the data of the sonarqube. For this we have created new RDS instance with PostgreSQL db for Sonar. Also, added the env variables consisting of JDBC URL, UN and PWD in the ECS tasks definition.

After that we started the SonarQube ecs service, the service and tasks both are up and running. However, in the system dashboard it is showing H2 database instead of PostgreSQL db.

Please find the ecs logs for the same:

2024.02.23 07:29:42 INFO app[][o.s.a.ProcessLauncherImpl] Launch process[COMPUTE_ENGINE] from [/opt/sonarqube]: /opt/java/openjdk/bin/java -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djava.io.tmpdir=/opt/sonarqube/temp -XX:-OmitStackTraceInFastThrow --add-opens=java.base/java.util=ALL-UNNAMED --add-exports=java.base/jdk.internal.ref=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/sun.nio.ch=ALL-UNNAMED --add-opens=java.management/sun.management=ALL-UNNAMED --add-opens=jdk.management/com.sun.management.internal=ALL-UNNAMED -Dcom.redhat.fips=false -Xmx512m -Xms128m -XX:+HeapDumpOnOutOfMemoryError -Dhttp.nonProxyHosts=localhost|127.*|[::1] -cp ./lib/sonar-application-9.9.3.79811.jar:/opt/sonarqube/lib/jdbc/h2/h2-2.1.214.jar org.sonar.ce.app.CeServer /opt/sonarqube/temp/sq-process17422359710125694681properties


In the logs, it is showing H2 database, but not PostgreSQL db.

Requesting you to analyze and let us know how this Sonar Service will fetch PostgreSQL db details.

Hi,

Welcome to the community!

How are you providing the DB details to SonarQube? Note that in SonarQube 9.9, support for the deprecated SONARQUBE_JDBC* properties was dropped. You need to make sure you’re using SONAR_JDBC* properties.

 
HTH,
Ann

1 Like

Hello Ann,

Greetings!!

Appreciate your response. We tried your suggestions, but we got following error.

**:ERROR: [1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch. **

bootstrap check failure [1] of [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

Can you please suggest, is there any option to disabled the mmap bootstrap check.

Or different image, I have tried with 9.9.4 as facing same issue.

Thanks in advance.

Hi,

So it looks like you passed the database hurdle and are on to the next one. Normally, I’d say that this is a new question and it deserves a new thread. If SONAR_ES_BOOTSTRAP_CHECKS_DISABLE=true doesn’t work for you, then please do create a new thread.

 
Ann

1 Like

Dear Ann,

That solution suits me well! I was able to retrieve the configured DB details. Impressive work! I really appreciate your prompt and accurate responses to my questions. I’m happy that we connected.
Have a wonderful day and stay blessed.

Regards,
Viraj S

1 Like