SonarQube automatically getting stopped after i start through sonar.sh file

Hi Team ,

Whenever i try to start sonarqube using the sonar.sh script ,it starts but it automatically stops after 1 or 2 seconds,have never encountered this issue before.

Can you please let me know what needs to be done to fix this ?

Output of : tailf sonar.log

Socket read no code(closed?)
Server listening on port 32001
Wrapper manager: shutdownhook complete
Server daemon shutdown
VM exited normally
Signal trapped. Details:
Signal number=17 (SIGCHLD) , Source=“unknown”
Recieved SIGCHLD, Checking JVM process status
JVM process exited with a code of 0 , leaving the wrapper exit code set to 0
Wrapper stopped

Hi @ALAKA_BHATTACHARYA ,

Welcome to SonarSource Community! :sonarsource:

What version of SonarQube are you using?

Please check your log files and see if you have any other errors that stand out. Please see Server Logs & System Info | SonarQube Docs for more information.

Also, please ensure you’re not running sonarqube as root, which we discuss here in Operating the Server | SonarQube Docs documentation:

On a Unix system using SystemD, you can install SonarQube as a service. You cannot run SonarQube as root in 'nix systems. Ideally, you will have created a new account dedicated to the purpose of running SonarQube.

Make sure that all of the files in the directory for SonarQube are owned by the user you are logged in as.

Please review this other post that may help you: SonarQube fails to start in console

Joe