SonarQube Admin

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) v10.0.0
  • how is SonarQube deployed: zip, Docker, Helm zip
  • what are you trying to achieve
  • what have you tried so far to achieve this

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!


I have installed sonarqube 10.0.0 using zip media and installation was successful using embeded database. I changed the default password for admin account on the prompt and able to login.

After my installation was completed, I have changed my file to external database (MSSQL Server) and application was stopped and started back again. After I got login page, the initial admin user and changed password doesn’t work anymore. I assume it is because the user and password is being used in embeded database.

I even tried re-installing the app and install using the external DB but it never prompted to change the password again. I need temporary admin access before we do the migration of the heritage system.

Can someone share any idea on this ?

Bipin Guragain

Hey there.

Try clearing your browser cache/cookies.