sonarqube-9.8.0-Highdiskwatermark [90%] exceeded on [][/opt/sq/sq-]

I have just finished setup a fresh new SQ install and in the config files I added

ad the main disk has only 2Gig of free space. After successful start, I get always the following as if the properties I added were not taken into consideration

2022.12.30 19:30:28 WARN  es[][o.e.c.r.a.DiskThresholdMonitor] high disk watermark [90%] exceeded on [GHKrUyhfQ-KIlcrH41Omkg][sonarqube][/opt/sonarqube/sonarqube-] 
free: 1.9gb[5.1%], shards will be relocated away from this node; currently relocating away shards totalling [0] bytes; the node is expected to continue to exceed the high disk watermark when these relocations are complete
2022.12.30 19:30:28 INFO  es[][o.e.g.GatewayService] recovered [7] indices into cluster_state
2022.12.30 19:30:57 INFO  es[][o.e.c.r.a.AllocationService] Cluster health status changed from [RED] to [GREEN] (reason: [shards started [[components][2], [components][4], [components][3]]]).
2022.12.30 19:30:58 INFO  app[][o.s.a.SchedulerImpl] Process[es] is up

then when I run analysis in my Azure devops online, all steps succeeds except the 3rd one

How can I force SQ to use the other disk, am I missing something?


Elasticsearch has built-in safeties & shuts down if the free disk space is below a certain percentage of the total disc size - regardless of how big the free space is.

That said, the warning you’re getting does indicate that your properties aren’t being taken into account. Where/how are you setting them?


Hi Annm while I was waiting for a response, I discovered down in the config files line 423 and 424, 2 lines

it seems that they had precedence on my config. I commented them out and SQ is working like a charm since

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.