SonarCloud: Could not resolve xx file paths in []


In one of our projects in Typescript we are always having code coverage 0.0%.
Looking to the pipeline logs I found this warning:

WARN: Could not resolve 55 file paths in [/builds/zqyy6WLr/0/mnk-group/]

Here it’s the full output in verbose mode.
pipeline-log.txt (206.0 KB)

I found topics in this community alerting to issues regarding relative or absolute paths in file, we tested both, but in this case nothing worked, in both cases we have the same error.


sonar.projectKey = mnk-group_scrts-twl-test
sonar.organization = mnk-group
sonar.projectBaseDir = functions/
sonar.javascript.lcov.reportPaths = coverage/
sonar.scm.exclusions.disabled = true
sonar.verbose = true

We are using SonarCloud and our pipeline is in Gitlab.
The sonar job in our pipeline:

Sonarcloud Check:
  stage: sonarcloud-check
    name: sonarsource/sonar-scanner-cli:latest
    entrypoint: [""]
    SONAR_USER_HOME: "${CI_PROJECT_DIR}/.sonar"  # Defines the location of the analysis task cache
    GIT_DEPTH: "0"  # Tells git to fetch all the branches of the project, required by the analysis task
    key: "${CI_JOB_NAME}"
      - .sonar/cache
    - sonar-scanner
    - merge_requests
    - master
    - develop
    - /^release.*$/
    - /^hotfix.*$/
  allow_failure: true

Some quick points:

  • Tests are executed.
  • Tests are detected by SonarCloud.
  • LCOV report is being generated by jest.
  • SonarCloud points to the correct LCOV report location.

Is there something wrong in our configuration?


I notice you’re setting sonar.projectBaseDir. That’s not typically needed and could(???) be throwing off the path question. Can you analyze without it?


Hi Ann,

I tested without sonar.projectBaseDir but I had the same error.


Thanks for the followup. I think this requires language-specific expertise, so I’ve added the typescript tag to draw that attention. Hopefully they’ll be along soon.


same problem here, any solution?

Hello @Daniel_Gil,

Sorry for the long delay in answering you. Are you still experiencing this issue?


Hello @gabsmprocha,

Would you mind creating a different thread for your problem?


a) why new thread?
b) is there a new thread?
c) is there a solution, we lost coverage reports which is very bad

Hello @Predrag_Stojadinovic,

Welcome back among us!

a) why new thread?

It’s a case-by-case suggestion. Here, we got a user apparently facing the same issue as the author of this thread. The problem was initially reported in early March 2022 without any response since my last message. Therefore, there is no guarantee that it’s the same problem since quite some time has passed.

b) is there a new thread?

Not that I am aware of.

c) is there a solution, we lost coverage reports which is very bad

Before getting to the solution, we first need to understand the problem. This is why I am suggesting creating a new thread, asking to share analysis logs and contextual information that would help investigate what is going wrong.

Hope this answers you,