Sonarcloud can not find pullrequest in azure devops

I have been having problems with Sonarcloud not being able to find my pullrequests for specific repositories.
The issues have been going on for about two days now.

The repositories are hosted in Azure DevOps where we also run the PR’s.

##[error]ERROR: Error during SonarScanner execution
ERROR: Error during SonarScanner execution
##[error]ERROR: Could not find the pullrequest with key ’ ’

I have checked that the PAT’s are still valid and have even tried replacing them with a new one.
I have also checked that I can reach the repository from the devops icon in sonarcloud.

I don’t believe this issue can stem from the integration from devops to sonarcloud as this should affect all repositories in the devops project and not a select few. Update: I have checked that the service connection from devops to sonarcloud is healthy.

I have seen posts from other people with similar issues, although most of those were solved by updating the PAT and the ones, where the PAT’s were in order, did not contain a resolution.

Anyone who has experienced this or have any idea as to how I can move forward?

Hey there.

Is this the actual log line, or did you remove the PR ID?

Hi Colin,
I did remove the PR id.

The problem has now been fixed.

It turns out that some of our projects were bound to Azure DevOps and only these failed.
All the unbound projects worked fine even though the repositories are also integrated with devops.

The bound projects failed as the Organization level personal access token was invalid.
It is my understanding that bound projects use the organization PAT and unbound projects only use the PAT setup on the projects themselves.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.