Sonar setting New Code - Project setting is not persisted

SonarQube info

  • versions used: 8.9

Hello SonarSource team,
I would like to report the following discrepancy/bug.

When I try to set New Code - Project setting to Define a specific setting for this project – Reference branch Develop (MAIN BRANCH) for our branch it is not persisted.

It seems it is saved, but after navigating away and back the old one is here.

Screen after my setting:

Screen after refresh:

Could you please take a look?

Thank you very much

Hello @puci ,

I’ve failed to reproduce that issue, so I need few more details from you.

  • Do you see any error in web console of the browser?
  • What exactly version and edition of SQ are you using (developer, enterprise, datacenter)? Please provide version in X.Y.Z format
  • Could you clarify step by step what lead to that situation, I’m not sure if I understand correctly from your screen what happened first.

Hi @jacek.poreda ,
thank you very much for your answer. It was SQ EE 8.9.1, no log/error was created for me. However, I solved the error by updating SQ to a higher version and everything works for me there.
So I have already solved the problem, I did not come to an error.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.