Sonar Report not reflecting recent data

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) 9.9.2
  • what are you trying to achieve
    User has made changes to the Sonar as per the report, user has corrected all the changes and trying to update in the release branch but that its not reflecting the recent report information
  • what have you tried so far to achieve this
    Tried to copy from release branch and correct data is being reflected but when pushing from copied branch to release branch the information is not getting reflected

debug-unit-testing-sonarqube-coverage-analysis-4.0.0.log (97.6 KB)
debug-unit-testing-sonarqube-coverage-analysis-CLS001.log (92.2 KB)


To be clear, you:

  • ran an analysis
  • addressed issues, coverage, etc
  • re-ran analysis

And the analysis results don’t reflect the changes that were made?

Are you sure the latest version of the code was checked out to run the analysis on?


Hi Ann,

Yes, user made changes to the code but still its not getting reflected
Asked user to use a different release name but still no go!


Thanks for the screenshots. They’re almost always helpful!

I see

branch perspective last analysis New Code definition
release/1.4.0 New Code 23 May 2023 since 6 Jan 2023
feature/CLS-14707-1 New Code 20 Nov 2023 since 8 Nov 2023
release/4.1.0 Overall Code 17 Nov 2023 since 4.0.0-SNAPSHOT

I’m not sure how these are supposed to relate to one another.

But looking at the release/4.1.0 version, you’re down to only 1 bug overall, which seems pretty good.

I suspect there’s a fundamental disconnect here about what the expectations should be. Could you be more explicit about how you believe these screenshots should relate to one another and what you expected to see happen?


Hi Ann,

I think I made a mistake, instead of 4.1.0 I sent a screenshot of 1.4.0.

we have to look at only 2 branches, 14707-1 whose quality gate is passing and branch 4.1.0 in which 14707-1 got merged.

so our expectation is branch 4.1.0 should pass quality gate as all the fixes which were made in branch 14707-1 are now present in branch 4.1.0

Hi Ann,

Please confirm if related to below bug:


That issue is unrelated.

If you’re expecting 14707-1 to fix all the issues in 4.1.0, then you should be comparing apples to apples. You’re looking at (or at least, you provided a screenshot of) “New Code” in 14707-1, and Overall Code in release/4.1.0.

What does the 14707-1 Overall tab look like?

Also, how many other branches - in addition to 14707-1 - have been merged into release/4.1.0? They could have introduced issues.