Sonar Lint for IBM IID 8.5.7

i am trying to install sonarlint in IBM’s IID (8.5.7), with no luck. Getting below errors and tried using jar signer as suggested by eclipse for this issue in https://bugs.eclipse.org/bugs/show_bug.cgi?. It is not working.

In the case of IID 8.5.7, version of Eclipse is 3.6.2. Could you please let me the exact plugins to use for this version of eclipse. This is urgent for us, please let us know the solution.

below are errors I am getting:

An error occurred while collecting items to be installed
session context was:(profile=bootProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.cdt,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile120847803386310686.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile120847803386310686.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.cdt.source,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile2243073342536283284.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile2243073342536283284.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.core,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile977837314350883401.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile977837314350883401.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.core.source,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile1480863157762585248.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile1480863157762585248.jar
Problems downloading artifact: org.eclipse.update.feature,org.sonarlint.eclipse.feature,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile4558825278182393168.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile4558825278182393168.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.jdt,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile5757266267651176031.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile5757266267651176031.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.jdt.source,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile3733491933577443926.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile3733491933577443926.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.m2e,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile8380095327470134908.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile8380095327470134908.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.m2e.source,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile5999984259943414579.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile5999984259943414579.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.ui,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile7120429907421229121.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile7120429907421229121.jar
Problems downloading artifact: osgi.bundle,org.sonarlint.eclipse.ui.source,3.6.0.201806071228.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile8734339410114328728.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile8734339410114328728.jar
Problems downloading artifact: osgi.bundle,org.sonarsource.sonarlint.core.sonarlint-client-api,3.7.0.1730.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile8322691224315573241.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile8322691224315573241.jar
Problems downloading artifact: osgi.bundle,org.sonarsource.sonarlint.core.sonarlint-core,3.7.0.1730.
Error reading signed content:C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile5502859841680296251.jar
An error occurred while processing the signatures for the file: C:\Users\RAMYAS~1.P\AppData\Local\Temp\signatureFile5502859841680296251.jar

I think the problem is that your version of Eclipse is too old. For your information, we are only testing with Eclipse 4.6 and later. It may work with older versions supporting Java 8 (4.4+), but with no guarantee. 3.6 is definitely too old.

Hi Julien,

IID is built on top of eclipse 3.6.2, could you please provide plugin for sonar lint which are compatible with this version of eclipse.

Thanks,
Ramya

Unfortunately this is not in our short term plans. FYI all our code analyzers are written in Java 8+, so that would be very difficult to retrofit all our ecosystem to older versions of Java. Not talking about the fact those old versions are not supported anymore :wink: