Sonar 7.2.1 not starting


(Mohammed Ibrahim) #1

sonar stop progressing after this statement in log

jvm 1    | 2018.07.09 11:02:50 INFO  app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /home/sonar/Elasticsearch/temp
jvm 1    | 2018.07.09 11:02:50 INFO  app[][o.s.a.es.EsSettings] Elasticsearch listening on /127.0.0.1:9001
jvm 1    | 2018.07.09 11:02:51 INFO  app[][o.s.a.p.ProcessLauncherImpl] Launch process[[key='es', ipcIndex=1, logFilenamePrefix=es]] from [/home/sonar/sonarqube-7.2.1/elasticsearch]: /home/sonar/sonarqube-7.2.1/elasticsearch/bin/elasticsearch -Epath.conf=/home/sonar/Elasticsearch/temp/conf/es
jvm 1    | 2018.07.09 11:02:51 INFO  app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
jvm 1    | 2018.07.09 11:02:53 INFO  app[][o.e.p.PluginsService] no modules loaded
jvm 1    | 2018.07.09 11:02:53 INFO  app[][o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]

(Nicolas Bontoux) #2

Hi there,

The troubleshooting documentation is a good place to start from. Make sure to check all log files, and look for the error that would be fatal.


(Mohammed Ibrahim) #3

Hi,

thanks , troubleshooting didn’t help me, i have only sonar.log , there are no other log file generated .

regards,


(Nicolas Bontoux) #4

Hi,

I would suggest going through this thread first then:

Similar startup issue, and various considerations that might help you moving forward on this.


(Mohammed Ibrahim) #5

thanks,
still the same issue …


(Nicolas Bontoux) #6

I suggest you take a step-by-step troubleshooting approach then:

  • look at the CPU/RAM state of your machine as SonarQube starts-up, see if anything stands out (or if there’s any resource starvation anywhere)
  • verify JVM settings you’ve defined/modified in sonar.properties
  • enable debug logs in sonar.properties if still clueless
  • check sonar.log content, and most importantly check content of all files in logs directory

If still mysterious then you will have to share more input if you expect more input/help. Config files, content of logs directory, findings and things you’ve tried etc.