[SOLVED] Okta SCIM Endpoint Missing from 9.8

Must-share information (formatted with Markdown):

  • Version 9.8 (build 63668) Enterprise
  • Enable Okta SCIM
  • Followed the setup instructions, and attempted to connect to the documented /api/scim/v2 endpoint with an authenticated user. I attempted to restart the service after enabling SCIM in SonarQube, but it had not affect.

I am attempting to setup the Okta SCIM integraion, but Okta was throwing an error. When I check the documented endpoint, I get the following response:

{"errors":[{"msg":"Unknown url : /api/scim/v2"}]}

I tried looking at the API docs with the internal endpoints included, but I don’t see any SCIM related endpoints.

Edit #1:

I just tried setting the sonar.scim.enabled setting to true in the helm chart, but it did not change anything. When I enable it in the UI and then use curl to check the setting in the API I get back the following:

curl -s -L -u "squ_secretvalue:" --basic https://sonarqube/api/settings/values?keys=sonar.scim.enabled | jq
  "settings": [
      "key": "sonar.scim.enabled",
      "value": "true",
      "parentValue": "false"
  "setSecuredSettings": []

Edit #2:

It looks like there was some confusion about the username/password. We have sorted this out and the password setting is now empty Okta, and the username is the user token.

1 Like