Setting up Sonar Cloud with BitBucket

How are you doing, hope everything is find at your end. We are using Sonar Cloud for the first time to integrate with our BitBucket and we are facing challenges to set up in our BitBucket. We tried following the documentation(from Sonar Cloud Documents) to set up but we are still facing challenges to set up where we need to add the scripts in Pipeline(.yml) file and we are not sure if we add the scripts that might break something in out BitBucket. Please help us to configure Sonar Cloud with our BitBucket.

Hi @Sanjay_Singh_N,

Welcome to the community forum!
Could you clarify which part of the documentation pages would require clarification?
I believe the right pointers are:

Hi Alex,

Thank you for the reply, we followed as it was recommended where we got a reply to our previous post from my colleague and also we are not sure if we change anything in Pipelines we may break something in our bitbucket so we are seeking help here on screensharing.

Link: https://sonarcloud.io/documentation/integrations/bitbucketcloud/

Hi @Sanjay_Singh_N,

What makes you think that SonarCloud integration would break something in bitbucket ?

Have you tried to follow the tutorial in the product (’+’>‘Analyse new project’>select a repository>analyse with bitbucket pipelines), the steps are explained to set up the analysis with bitbucket pipelines?

Cheers,

Dear @Sanjay_Singh_N, we do not provide help through screen sharing. I also perceive that your question is Bitbucket specific. Perhaps you should seek help on that particular domain.

Hello @Sanjay_Singh_N,
There was no news on this since a while. I was wondering if you managed to do what you wanted ?
Just as a follow up on the last posts

  • First of all, rest assured that whatever you try regarding SonarCloud integration, this will not break your Bitbucket !
  • As mentioned earlier, we don’t provide screenshare support. However there is plenty of inputs that you can provide that can facilitate the resolution. So far you only gave high level description of what was going on. Let’s get in the details. So:
    – Please first explain what you mean by set up ? What do you expect as result ? Your bitbucket analyzed in SonarCloud ? Your bitbucket repos pull requests decorate ? Please explain
    – Once your objective has been clarified please explain what documentation/guidelines you followed (pointing at the specific online documentation pages if any)
    – Confirm what you did with screenshots of a) the relevant SonarCloud pages (eg the bitbucket integration wizard pages in SonarCloud and b) some screenshots of your Bitbucket if you’d expect something that you don’t see for instance.
    Alternatively, if you bypassed the wizard and did the integration manually, please explain what you did
    – If you run something (eg a SonarScanner) and that something does not work, please send the logs of the scanner execution

Regards, Olivier

1 Like

Hi there,

we managed to set up BB pipelines with sonarcloud and it shows the widget on the “source” page (after it has been run on the master branch). It does not show on the PR UI though. It just says “Code Quality” above the PR description and nothing below that header. I can’t really find any info on it, but I guess it should show a widget there, to see if any new issues (bugs, code smells, whatever) have been introducted with this PR - right?

I confirmed that all pipeline steps have been run on this PR. It successfully got executed and sonarcloud-scan:1.1.0 as well as sonarcloud-quality-gate:0.1.3 were built.

I’d appreciate any help on this and also how it’s supposed to look like.

BR

Right! Unfortunately this is a known issue with ad blockers and similar browser plugins (AdBlock+, Ghostery, etc…), and out of our control. If you disable such plugins for bitbucket.org, then it should become visible on page reload, and look something like this:

2 Likes

@janos ah that seems to be the case, thanks for the hint. It only works when completely disabling uBlock for the whole of bitbucket, is there a way to just whitelist a specific domain? I did allow sonarcloud.io, but that does not seem to work on it’s own. Or is this a bitbucket issue with the way the integrations work? The widget on the “Source” page is showing up just fine with uBlock enabled.

Never had those problems with GitHub Integrations…