Setting sonarqube on iis reverse proxy with ssl from cloudflare

Hi everyone,
This is the first time for me to install and configure sonarqube.
I have installed sonarqube developer edition on my Azure VM. i want to integrate it with Azure devops pipeline. As sonarqube runs on localhost:9000 by default, I have generated csr from iis for ssl and had it binded with cloudflare.
I setup iis server to use as reverse proxy with hostname as sonar.mycompany.com on https with the help of URLrewrite and ARR.
Finally when i run the application from iis it is showing Error 522 : connection time out where browser working fine, cloud flare working fine and Error at Host.

Application pool is : sonar.mycompany.com
port:442
SNI enabled
rewirte rule : sonar.mycompnay.com:9000
X_FORWARDED_PROTO enabled in rule
rewrite to : http://sonar.mycompany.com:9000{R1:

sonarqube redenring fine on localhost:9000 and publicIp:9000 as Sonar.web is set to 0.0.0.0
when i run application on iis, https://sonar.mycompany.com, ssl is enabled but connection time out occuring.

kindly help me out.

Hi,

Welcome to the community!

The docs point to this blog post for using IIS as a proxy.

You may find it helpful.

 
Ann

Hai Ann,
Thank you for your response.
Actually, Thats the blog post i have followed in setting up sonarqube on iis reverse proxy and the error im getting is the host is not reachable.

Hi,

Which host? SonarQube? You might want to talk to your network folks.

 
Ann