Sensor Zero Coverage shown in sonar-scanner

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) SonarQube community version 8.9.9
  • what are you trying to achieve Code coverage for C++
  • what have you tried so far to achieve this — following steps done:

mkdir coverage-dir
cd coverage-dir
find … -name “*.o” | xargs gcov –preserve-paths
cd …
sonar.cfamily.gcov.reportsPath=”coverage-dir” – entry in
It shows Sensor Zero Scanner

sonarqube still shows coverage as 0.0%

2nd scenario: created coverage.xml using gcovr (version 5.1)

gcovr –keep –use-gcov-file -r . –xml-pretty -o coverage.xml

modified to sonar.coverageReportPaths=coverage.xml

Still same error as mentioned above

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

Can someone please look into my issue?


What edition are you using? In case you’re not sure, you can find it in the page footer.


I am using commmunity 8.9 edition


Community Edition doesn’t support C++. If you’re using a 3rd-party plugin for that support, then you’ll need to speak to its maintainers.