Random Logout Enterprise Edition

Hello,

Having just upgraded to the Enterprise Edition latest (9.2.4) from the Community Edition 8.9 LTS there is now the following new popup bottom right:

image

Clicking on the ‘Dismiss’ link immediately throws a 401 and sends the user to this page.

image

The Chrome Developer console indicates an API call that fails

No other links cause this problem and browsing the rest of the site has no issues so this seems like a the user does not have the permissions required to call this API.

We use your SSO method of Header Auth behind nginx and keycloak. The correct Forwarded values as per the user documentation are set.

X-Forwarded-Login
X-Forwarded-Name
X-Forwarded-Email
X-Forwarded-Groups

as well as the required:

X-Forwarded-For $remote_addr;
X-Forwarded-Proto https

Users have ‘Browse’ and ‘See Source Code’ permissions.

Any assistance would be greatly appreciated. For example is there a way to disable this popup globally even if temporarily.

Thanks in advance.

Will

1 Like

This appears to be resolved by clearing all cookies - potentially an early cookie from the sonarqube login method (ldap) is interferring. Taking this into account would be helpful.