Pull request decoration did not happen for BitbucketCloud

bitbucket
pull-request

(Olexandr Kuper) #1

I am seeing this warning in my PR-page on SonarCloud.

Pull request decoration did not happen. Please install SonarCloud application on the Bitbucket repository’s organization or user.

It worked fine till 11-th January, this problem has been started from 14 January.

The main problem: SonarCloud doesn’t publish results to BitbucketCloud PR (commit).

I mean next(second result):

I tried to reinstall application ‘SonarCloud’ on Bitbucket Cloud, but it does not help.


(Michal Duda) #2

Hi,
Is the repository that you are targeting with your PR registered to your user or to one of your teams?


(Olexandr Kuper) #3

Hi, thanks for the response

Repository registered to one of my teams.


(Michal Duda) #4

Do you have the SonarCloud app installed for your team or only for your user? If the repository is assigned to the team the app has to be installed in that team settings.


(Olexandr Kuper) #5

Yes, it’s installed in the team.


(Jonathan Krengel) #7

I seem to have the same problem on only a few of our projects.

PR on 11th shows the decoration and PR on the 14th does not. I also can’t see any more PR analysis inside sonar cloud, so the analysis is not happening at all.


(Olexandr Kuper) #8

Any updates ?


(Michal Duda) #9

Hey,
Due to the GDPR changes in BitbucketCloud API, SonarCloud no longer supports using owner and repository slugs in:

  • sonar.pullrequest.bitbucketcloud.owner

  • sonar.pullrequest.bitbucketcloud.repository

You have to supply UUIDs in these two parameters. We forgot to update the SonarCloud docs, apologies for that, we will correct it soon. For Bitbucket Pipelines these two parameters are not needed at all since these will be autodetected. For Jenkins you can fetch the owner and repository UUID using something like https://github.com/jenkinsci/bitbucket-plugin.


(Olexandr Kuper) #10

I tried to use UUID but it does not help.


(Michal Duda) #11

Are you using exactly the same format of the UUID that is returned by Bitbucket (so with curly brackets like for example this "{00836e58-dc79-4a8d-bc69-6f2003b95087}")? If yes and it still doesn’t work please send me the UUID in a private message or email.


(Olexandr Kuper) #12

Hi Michal,

Thank you very much for help UUID partly fixed the issue on SonarCloud PR screen.

I mean so the SonarCloud still not publishes commit result to status build on BitBucket (like on the first screenshot), but BitBucket PR-link is accessible from SonarCloud.

Do you have any idea about this issue?


(Michal Duda) #13

Hi,
After fixing the UUID, do you get any warnings in SonarCloud after the analysis? Can you send me the logs of the full analysis (privately)?


(Olexandr Kuper) #14

No, after fixing the UUID warnings are gone. I mean SonarCloud not publish results to Bitbucket Builds (like on the screenshot in this issue)


(Michal Duda) #17

Hi Olexandr,
This is a problem on SonarCloud side. It will be resolved after the next SonarCloud deployment- I’ll make a post once it’s done.

Thanks for reporting this and all the help!


(Michal Duda) #18

The fix has been deployed. Can you recheck if everything is fine for your pull requests?