Proxy pass error deploying sonarqube, please help


(Michaël Robaston) #1

SonarQube 7.4
Apache2.4
Debian Jessie 8

Im encountering difficulty to deploy sonarqube

Here is the log apache2


(Alexandre Frigout) #2

HI,

Please check if you have set the sonar.web.context parameter in your sonar.properties file ?
The sonar.web.context parameter must start with a /.
If yes, you need to add it to your apache configuration.

Alex.


(Michaël Robaston) #3

hi thanks for answer

is it good ?

image


(Michaël Robaston) #4

ProxyRequests Off
ProxyPreserveHost On

<VirtualHost *:80>
ServerName sonarqube.stream-techs.com
ServerAdmin admin@stream-techs.com
DocumentRoot /var/www/sonarqube-7.4/web/
<Directory “/opt/sonarqube/sonarqube-7.4/data/web/”>
Options Followsymlinks
Require all denied

            <Directory "/opt/sonarqube/sonarqube-7.4/data/web/">
              Options         +Followsymlinks
              AllowOverride   All
               Require         all granted
           </Directory>

<Proxy http://sonarqube.stream-techs.com:9000/*>

ProxyPass /sonar http://sonarqube.stream-techs.com:9000/ retry=0 Keepalive=On timeout=1600
ProxyPassReverse /sonar http://sonarqube.stream-techs.com:9000/
AllowEncodedSlashes NoDecode
TransferLog /var/log/apache2/sonarqube_access.log
ErrorLog /var/log/apache2/sonarqube_error.log


(Colin Mueller) #5

Greetings,

We document here a suggested starting configuration for SonarQube being served by apache.

Where did your other values, such as specifying directories, come from?

Colin


(Michaël Robaston) #6

Hi colin

This Vhost is not working weirdly…

I tried 20 times to setup it …


(Alexandre Frigout) #7

Hi,

you set a context /sonarqube in the sonat.properties file but it is not reflected into your proxy configuration. This is very probably why you have trouble.
Every occurrence of http://sonarqube.stream-techs.com:9000/ should be replaced with http://sonarqube.stream-techs.com:9000/sonarqube into your proxy configuration.
Then, according to your ProxyPass parameter, you would be able to reach your sonarqube by browsing sonarqube.stream-techs.com/sonar.

remove the <Directory .... configuration from your virtualhost, only the proxy parameters are necessary.

Alex.