Provided Node.js executable file does not exist

I am running Jenkins in a Docker container with Sonarqube. When executing sonar-scanner, I got the error that node exe was missing. As described in many answers i put this “sonar.nodejs.executable=/usr/bin/nodejs” In my config file but it says that it doesnt exist. I’ve tried it with just node instead of nodejs too, no difference. I am sure node is installed because I can do node -v and get the version. What am I doing wrong? The location is right as well because I can do this “/usr/bin/nodejs -v”
My goal is to analyze my Node code

Hi @manoloromero ,

Welcome to SonarSource Community! :sonarsource:

Are you using the Node.js plugin for Jenkins? Or are you installing Node.js on your host machine?

Maybe these links will help:


Hello Joe,
first of all thanks for the quick reply! Great service.
Second, the first link you sent (indirectly)helped me. I previously linked the executable to /usr/bin/node which wouldn’t work, but the link you sent mentioned the plugin installation and when I tried that “sonar.nodejs.executable=/var/jenkins_home/tools/” , it worked! So problem is solved, now I have some work to do in fixing the code smells discovered by SonarQube :stuck_out_tongue:
Thanks a lot and have a great day/night/week!

1 Like

@manoloromero Good to hear it worked out for you. Thank you for letting me know. Good luck with your SQ experience :tada:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.