Project import not working on target UI

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension): 8.4.1
  • what are you trying to achieve: Moving same project information from one sonarqube instance to another sonarqube instance
  • what have you tried so far to achieve this: Exported and imported the file/directory from source & target server respectively.

Able to view the zip file on target server, please refer below.

bash-5.0$ cd /opt/sonarqube/data/governance/project_dumps/import
bash-5.0$ ls -l
total 44
-rw-r–r-- 1 sonarqub sonarqub 42154 Jun 20 17:32

Same source project key used to create the project on target UI but import option is still disabled.

Source & target sonarqube versions are 8.4.1 - Enterprise Edition.

Screenshots attached


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.4.1 → 8.9.8 → 9.5 (last step optional)

You may find the Upgrade Guide helpful. If you have questions about upgrading, feel free to open a new thread for that here.

Once your upgrade is complete, please see the docs on export/import.


I need to migrate the sonarqube database and it’s not possible to upgrade now. We will the upgrade for next month. Could you please help to migrate the database now.

We are using the enterprise edition 8.4.1 in both the Sonarqube environments.

Jagan Siram

Hi Jagan,

Your third screenshot indicates your export is named (I guess. It’s cut off.) Your first screenshot indicates you have a file in the correct directory named Your middle screenshot indicates that SonarQube can’t find a correctly named zip to import.

Somewhere in there it looks like your zip file got renamed…


We didn’t re-named the file anywhere. While exporting the file from source named as file and imported the file in same path shown in document but unable to import the project file in Sonarqube UI. We used same project key and project name in both source and target sonarqube UI. I followed the 8.4 version documention prior to start this activity. You have also suggested this option in different mail thread last week.

Please assist on where we renamed the file and if file got renamed where I need to check it.

Thanks for your support!
Jagan Siram

Hi Jagan,

From the 8.4 docs, when you export:

A zip file containing all project data ex is generated in $SONAR SOURCEHOME/data/governance/project dumps/export/_ named <project key>.zip

SonarQube exports a zip file named with the project key, and it expects to import a zip file named with the project key.


I’m unable to import the file from server stating “master” branch has not been analyzed yet and you have multiple branches already. It looks like it is not your Main Branch, check your configuration.

Please refer the attached screen shots and advise how to move these type of projects from source UI to target UI.


Have you checked the docs on this? You’re supposed to be importing into a provisioned, but otherwise empty project on the target server. The problem is just what the error message tells you:

If you really want to import this into the target server, you’ll need to delete the project there, re-configure it and then do the import without doing any analyses first.


Thanks for your response!

Yes, There are multiple branches in other projects as well and am able to import those projects now. Only this project, I’m unable to move to target server.

→ If i delete the project from the source server and re-configure it means will not have the project data available in the source server right? because we have migrated that github repo to different organization so we do not have repo available in github source. Please assist me how to move this project.

Error message attached.


That’s correct. That’s why you’re going to delete it on the target server. Not the source.


I mean if i delete the project on source server then will not have data/project available to reconfigure it.

I tried deleting the project on target server and imported again. But same result. Please advise how to move this project to target server.

Thank for your support Ann!


Which same result?

Please go to the docs I linked earlier and step through them.

Since we’re dealing with a version that’s long past EOL, that’s really all I can say. If that doesn’t work, then you’ll need to upgrade both the source and target instances and try again.


It’s giving me the same error(attached in my earlier messages) even after deleting the project and imported the project again. I have followed as per documentation to move the projects. Only projects which is in “failed” status unable to move it. Remaining projects which is in “passed” status able to move it.