PR decoration did not happen warning

SonarQube Developer 8.0, Gradle plugin 2.8, GitHub Enterprise Server

The PR decoration does work sometimes and did not work most of the time. I’ve confirmed multiple times that the repository identifier, GitHub app ID, and private key are all set properly.

I use Jenkins to invoke the build and to perform PR analysis.

2019.11.24 15:00:21 DEBUG ce[AW6d7XrYjXuc9iQAd7Sr][jdk.event.security] X509Certificate: Alg:SHA256withRSA, Serial:b259422ced9812a15a04e99528a0efa, Subject:CN=RapidSSL TLS RSA CA G1, OU=www.digicert.com, O=DigiCert Inc, C=US, Issuer:CN=DigiCert Global Root G2, OU=www.digicert.com, O=DigiCert Inc, C=US, Key type:RSA, Length:2048, Cert Id:624017625, Valid from:11/2/17, 12:24 PM, Valid until:11/2/27, 12:24 PM
2019.11.24 15:00:21 DEBUG ce[AW6d7XrYjXuc9iQAd7Sr][jdk.event.security] TLSHandshake: github.aws.na.xxx.net:443, TLSv1.3, TLS_AES_128_GCM_SHA256, 1254143766
2019.11.24 15:00:21 DEBUG ce[AW6d7XrYjXuc9iQAd7Sr][c.s.C.A.B.A.A.D] GET response did not have expected HTTP code (was 401): {“message”:"‘Issued at’ claim (‘iat’) must be an Integer representing the time that the assertion was issued",“documentation_url”:“https://developer.github.com/enterprise/2.18/v3”}
2019.11.24 15:00:21 TRACE ce[AW6d7XrYjXuc9iQAd7Sr][sql] time=1ms | sql=insert into ce_task_message ( uuid, task_uuid, message, created_at ) values ( ?, ?, ?, ? ) | params=AW6d7Yvsp8VyDPQBWVLy, AW6d7XrYjXuc9iQAd7Sr, Pull request decoration did not happen. Please install SonarQube Github application on the repository’s organization or user., 1574607621100
2019.11.24 15:00:21 INFO ce[AW6d7XrYjXuc9iQAd7Sr][o.s.c.t.p.a.p.PostProjectAnalysisTasksExecutor] Pull Request decoration | status=SUCCESS | time=572ms

I read this community topic which mentions that this could be due to a time drift between the servers. So I installed ntp on both SonarQube, and Jenkins server. But the issue still persist.

Is the issue with the time setting of the GitHub Enterprise server then? I currently don’t have access to it, so I’d like to make sure if that’s the problem before I could reach out.

I installed Chrony and find out that my system clock of SonarQube server was wrong by about 50 seconds.

Installing NTP didn’t help. Installing Chrony fixed the issue.