Permission denied

Good day, community.

I have the next error:

Injecting SonarQube environment variables using the configuration: sonar-server
[Pipeline] {
[Pipeline] sh
+ /var/jenkins_home/tools/hudson.plugins.sonar.SonarRunnerInstallation/SonarS
/var/jenkins_home/workspace/BuildDockerImageWithEnvVars-Sonarqube@tmp/durable-5952cc44/ 1: /var/jenkins_home/tools/hudson.plugins.sonar.SonarRunnerInstallation/SonarS: Permission denied
[Pipeline] }
WARN: Unable to locate 'report-task.txt' in the workspace. Did the SonarScanner succeed?

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    Sonar Qube: Community Edition Version 9.9.3 (build 79811)
  • how is SonarQube deployed: zip, Docker, Helm
    ECS Fargate + RDS PostgresSQL + EFS
  • what are you trying to achieve
    Run SonarQube in Jenkins pipeline
  • what have you tried so far to achieve this
    • Install java in container where the Jenkins running and it is the node where pipeline and jobs running
    • change permission for folder and file sonar-scanner

Looking for help.
Thank you for your time.
Best regards,


Welcome to the community!

This appears to be a permissions error

Have you made sure the build agent user has full permissions?


Hello, Ann.
Thank you for your answer.
It turns out, that I did not specify the correct path in the tool parameter. It should be:

By the way, If I may.

I want to make a secure connection to SonarQube server using ALB.
We configured alb to listen on port 443 and port 9000 and redirect to a target group that listens on port 9000, but it looks like Jenkins pipeline cannot pass this https.

What is the correct way to configure ALB on AWS with https and redirect traffic to the 9000 port on ECS(container service)?

Thank you!


I’m glad you worked through the first question. The second question deserves its own thread.