SonarQube is unable to analyze file

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • sonarsource.scanner version :
  • Sonarlint pluing version :
  • SonarQube Community Plugin version : 2.8.2
  • what are you trying to achieve
  • i tried to analyze my code on local.
  • what have you tried so far to achieve this
  • First, I tried sonarlint plugin and it failed(result says there is no issue even there is) due to runtime(i realized it then). Then i installed Sonarqube Community Plugin and did the settings accordingly. When i run it, it started to give the error below:
Java Main Files AST scan
1 source files to be analyzed
Error running SonarLint analysis SonarQube is unable to analyze file : ''
	at org.sonarsource.sonarlint.core.analyzer.sensor.SensorsExecutor.executeSensor(
	at org.sonarsource.sonarlint.core.analyzer.sensor.SensorsExecutor.execute(
	at org.sonarsource.sonarlint.core.container.analysis.AnalysisContainer.doAfterStart(
	at org.sonarsource.sonarlint.core.container.ComponentContainer.startComponents(
	at org.sonarsource.sonarlint.core.container.ComponentContainer.execute(
	at org.sonarsource.sonarlint.core.ConnectedSonarLintEngineImpl.lambda$analyze$0(
	at org.sonarsource.sonarlint.core.ConnectedSonarLintEngineImpl.withReadLock(
	at org.sonarsource.sonarlint.core.ConnectedSonarLintEngineImpl.withReadLock(
	at org.sonarsource.sonarlint.core.ConnectedSonarLintEngineImpl.analyze(
	at org.sonarlint.intellij.core.ConnectedSonarLintFacade.analyze(
	at org.sonarlint.intellij.core.SonarLintFacade.startAnalysis(
	at org.sonarlint.intellij.analysis.SonarLintAnalyzer.analyzeModule(
	at org.sonarlint.intellij.analysis.SonarLintTask.analyze(
	at org.sonarlint.intellij.analysis.SonarLintJobManager.lambda$runTask$1(
	at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(
	at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(
	at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(
	at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(
	at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(
	at org.sonarlint.intellij.analysis.SonarLintJobManager.lambda$runTask$2(
	at java.util.concurrent.Executors$
	at java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.util.concurrent.ThreadPoolExecutor$
Caused by: java.lang.NullPointerException
	... 33 more

Then i had tried to uninstall sonarqube plugin, nothing changed. Uninstall and install the intellij again : nothing changed.

i think, sonarqube community plugin broke something in my local and i could not revert it. Could you please help on this?

Thanks in advance.


SonarQube Community Plugin ( is an unofficial plugin not developed by SonarSource. Please use its own support channel to ask questions.

I’m not sure to understand correctly this sentence, by if you need help when using SonarLint, please describe your problem. For example if you think an issue should be reported and it is not, please give us the rule key of the rule you are expecting to raise an issue. And be sure to read the SonarLint FAQ for common reasons why SonarLint is not reporting issues.

We do face the same issue with Sonarlint v4.5.0.15320. A downgrade to v4.4.0.14142 worked for us at the moment.

This error has been fixed in SonarLint for IntelliJ 4.5.1 that has been released yesterday.