Not authorized to access sonarcloud with Azure DevOps

Greetings.

Recently my company purchased a SonarCloud subscription which we are using with Microsoft Azure DevOps pipelines. I’m unable to login in into “http://sonarcloud.io/” with my Azure DevOps account.
Only status message I get from the web-page is “You’re not authorized to access this page.”
Also, my Azure account has SounarCloud app enabled and thereof I see no reason why I can’t log in.

The e-mail to which my Azure DevOps account is bound is the same e-mail I’m currently using for this community forum account and I would like to keep it private.

Please help me with resolving this issue.
Regards.

Hi @KorkiFork and welcome to the community.

Is your Azure DevOps account a guest account ? Or is it part of an Azure AD ?

Thanks.

Hello Mickael.

I will have to guess the answer.
I’m not the project administrator, thereof I guess my account is considered to be a guest account.
The DevOps organization grants my account “Basic” access level.
My account has identical account type and permissions as accounts of my colleagues which also use SonarCloud but don’t have my issue with it.

Hi @KorkiFork Have you tried to connect from a private tab on your browser?

Hello Christophe.

Yes, I did that.
Also I tried with different browsers, deleting cookies, disabling/enabling SonarCloud permission in my Microsoft account and using SonarLint from VisualStudio.

Hello again.

I am still unable to log in into SonarCloud with my Azure DevOps account.
Do you have any suggestion on how to resolve this?

Hi @KorkiFork,

By “guest” account, i meant that your account is only part of an Azure DevOps organization, not a proper Azure AD. is that the case ?

Depending on your case, the authentication might not be supported, for example if your account is an Azure AD account, but has been declared into another Azure AD which holds the SonarCloud application.

Mickaël

@mickaelcaro
Yes, my Azure DevOps account is a guest account and its AD/guest status hasn’t’ been edited since it was created (it has always been a guest account only).
Please note my previous statement that my colleagues with same account types (only different mail addresses) don’ have this problem.

Can I expected any further support on this?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.