Noproxy support

proxy
sonarqube
webhooks

(Bob Rohan) #1

There are http proxy variables to enable access to the update centre via a proxy.

However webhooks are also being proxied now, so we need a noproxy variable to exclude specified hosts from being proxied


(Gilbert Rebhan) #2

Hi Bob,
the proxy settings needed for update center also affect sonarqube CE.
The nonProxyHosts setting works for me.
Here are the relevant parts of my sonarqube.properties:

# HTTP proxy (default none)
http.proxyHost=...
http.proxyPort=8080
# HTTPS proxy (defaults are values of http.proxyHost and http.proxyPort)
https.proxyHost=...
https.proxyPort=8080

sonar.ce.javaOpts=-server -Xmx4G -Xms512m -Xss1G -XX:+HeapDumpOnOutOfMemoryError -Dhttp.nonProxyHosts==heregoesyourspecifichost

Regards,
Gilbert


(Bob Rohan) #3

Thanks Gilbert, thats worked nicely.

I’ve utilised

# Same as previous property, but allows to not repeat all other settings like -Xmx
#sonar.web.javaAdditionalOpts=

I was slightly dubious about how this would hang together with the same property provided in run.sh via Dockerfile ENTRYPOINT. But it seems to be hanging together.