No report imported, no coverage information will be imported by JaCoCo XML Report Importer

We run the sonarqube command on the jenkins server
The maven command is as follows:

In the jenkins log we find that the single test coverage already has specific data, but it shows that no report can be imported。

Projects in sonarqube also cannot get coverage and unit tests, please tell me how to troubleshoot. Is there any problem with any configuration?

Developer Edition。 Ver


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.8.0 → 8.9.10 → 9.9.2 → 10.2.1 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.

Next year we purchased the enterprise version, are the steps for upgrading the version the same?
8.8.0 → 8.9.10 → 9.9.2 → 10.2.1 (last step optional)
8.8.0 → 8.9.10 → 9.9.2 → 10.2.1(最后一步可选)

Yes, it’s the same regardless of edition.

Hi! Our current version is * Enterprise Edition * Version 8.9.10 . The problem still occurs, do we need to upgrade to 9.9.2?

Did you setup your path to JaCoCo report and JUnit report?

It seems that it is not located at a default location.

Remember that jacoco “exec” file is no longer supported and you must generate your jacoco report in xml using: “mvn org.jacoco:jacoco-maven-plugin:report”

Check the documentation:

Best regards.

Hi Calero.We don’t specify the path to JaCoCo report and JUnit repor in Sonarqube or in the project POM file. Some projects are able to import the report successfully, but some don’t, which is something that strikes us as odd.

That’s because you are building your projects in a different way. You will have to provide more information because we are blind here.

As I told you before, on the screenshot provided, your parameter destfile for jacoco is an “exec” file and SonarQube no longer support this format to import the jacoco coverage. You must generate an XML file.