Lost access after Bitbucket migration

Hey guys,

My company recently migrated bitbucket to cloud plus there was company merger, and as the result my account changed its SCM to new one, as the result ( I only assume it is the reason ) I can’t access my SonarCloud Admin workspace, it is basically empty as workspace now and what makes it harder I was only one admin there.

Did anyone encounter same issue and can help pointing out how to solve it?
I tried updating my account to match old one, but now when I’m trying to login via BB I’m getting this error when redirected to SonarCloud via Microsoft SSO

Hello @Stepan_Kotyk,

Just to clarify the problem. You are logging in to SonarCloud with Bitbucket or Azure DevOps? Once you login with a different provider to SonarCloud, you are treated as a different user so you do not have access to your organization that you would otherwise have with a different provider. Is there anyone from the organization that is able to log in and add you as an admin?


Nope, Im only admin in that organization, so I need somehow restore access. How can this be done?

When having this error what is the URL of the website you are in? Is it SC throwing this error or BitBucket or AzureDevOps? It is not exactly clear for me.

Are you able to log in, for example using GitHub?

I will start a private thread with you to ask you for your details.


The topic has been solved in the private thread. The issue was lost access to the old organization as all members of that organization have now new accounts. We were unable to grant access to the organization for the new account as it was impossible to verify ownership.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.