Java 11 error upgrading to latest SonarLint in Eclipse 2019-09


I tried to upgrade from SonarLint 6 which as working to the latest version, 7.2, and the installation seemed to succeed but when Eclipse restarted, SonarLint does not appear in any menus and I saw errors like these in the error log:

  Unresolved requirement: Require-Bundle: org.sonarlint.eclipse.core
    -> Bundle-SymbolicName: org.sonarlint.eclipse.core; bundle-version=""; singleton:="true"
       org.sonarlint.eclipse.core [1054]
         Unresolved requirement: Require-Capability:; filter:="(&("
         Unresolved requirement: Require-Bundle: org.sonarsource.sonarlint.core.sonarlint-core-osgi; bundle-version="7.1.0"
           -> Bundle-SymbolicName: org.sonarsource.sonarlint.core.sonarlint-core-osgi; bundle-version=""

I installed a Java 11 JDK on my system, added it to Windows->Preferences->Java->Installed_JREs, made that the default and tried to install again but still got the same error. I realize that this may be more of an Eclipse question than SonarLint but does anyone know how to get this working or do I need to try to manually install from a previous version’s zip file?

Jack G.

Hello, welcome to the community! And thanks for your question.

SonarLint 7+ requires that Eclipse runs on Java 11+. You need to set it in your eclipse.ini file, please check the related section in the Eclipse wiki.

1 Like

Hi Jean-Baptiste, thanks for answering my question so quickly. That was exactly what I needed.

Unfortunately, it’s still not working because of a known bug (SonarLint for Eclipse fails in Windows when the Eclipse installation folder is "Program Files") but hopefully that will be fixed in the next release.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.