Is there an option to skip Text sensor while running sonar-scanner?

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    sonarQube - 9.3 , sonar-scanner - SonarQube Scanner 4.2.0.1873
  • what are you trying to achieve
    Running sonar-scanner for analyzing sql files
  • what have you tried so far to achieve this
    SCG scan gets completed but Text sensor runs too long, I would like to know how to skip it

Logs -
INFO: Sensor org.sonar.plugins.sql.sensors.CGIssuesSensor [sql] (done) | time=7013451ms
INFO: Sensor org.sonar.plugins.sql.sensors.SqlCoverCoverageSensor [sql]
INFO: Sensor org.sonar.plugins.sql.sensors.SqlCoverCoverageSensor [sql] (done) | time=2009ms
.
.
.
INFO: Sensor Text Sensor [text]
INFO: 11962 source files to be analyzed
.
.
.

how to skip above sensor as it takes too long

Hello,

Can you share the full logs of your scan because here I can’t see how long it takes?
Can you also clarify which infrastructure is used to scan your project?

In case you missed the post, the “Text Sensor” is used to detect presence of BIDI Characters to prevent trojan source attacks.

Thanks
Alex

It took 2hrs to reach this log => INFO: 1414/11962 source files have been analyzed
I cancelled it then as I’d to free the vm then. I am running the scanner on an ubuntu 20.04 vm in GCP. It’s an n2-standard-4 instance

Is it possible to skip it, may be I can run a separate scan for text sensor, first need to finish SCG scan and see the report

Hello Alexandre Gigleux,

Is there an option to disable it?

Regards,
Anoop