Intellij proxy tunneling authentication failure

I installed the plugin (SonarLint Intellij for but fail to connect to sonarQube server (https behind proxy).
Proxy settings are ok (clicking Check connection with the sonarQube server’s address gives me “Connection successful”).
However, when trying to connect to the sonarQube server with username/password (same one used successfully when connecting to sonarQube server from the browser) I am getting the error message:
Failed to connect to the server. Please check the configuration. Error: Fail to request https://.../sonarqube/api/system/status.
In the logs I see:
Caused by: Failed to authenticate with proxy at org.sonarsource.sonarlint.shaded.okhttp3.internal.connection.RealConnection.createTunnel(
I know about the restriction on Basic authentication for proxy tunneling after jdk 8u111, but I have already removed the restriction by setting the VM property -Djdk.http.auth.tunneling.disabledSchemes="" in idea64.exe.vmoptions (as well as that for the external jdk through
I’ve left it at that for the time being as I’m not sure what to try next.

Hello, thank you for your feedback and apologies for the late reply.

I suggest that you try with a more recent version of SonarLint for IntelliJ (most recent is 4.4 as of writing).

If the issue still exists, I suggest that you:

  • Try token-based authentication to connect SonarLint with SonarQube
  • Enable verbose logging in the SonarLint Log window and post relevant extract here

Hi, I am currently using, but unfortunately I still can’t connect using either username/password or a token.


Just to give an update on this topic: proxy issues are very hard for us to investigate, as there are so many different configurations, and we usually can’t reproduce the issue locally.
If you want to help us, you’ll have to give much more details, for example by using a network monitoring tool like wireshark and tracing requests.