Installing letsencrypt certificate on Sonarqube Server?

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension): 7.5
  • what are you trying to achieve: I have generated letsencrypt certificate in server but not able to get the web interface of sonarqube on https.
  • what have you tried so far to achieve this: I have generated letsencrypt certificate in server.

Hi @Amarnath_Jena ,

welcome to the community :wave:
in order to use TLS you have to configure it on your reverse proxy and not on sonarqube. You can find a guidline here

hope that helps (:

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {
server {
server_name sonarqube01.ho.mpgps.co;
ssl on;

listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/sonarqube01.ho.mpgps.co/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/sonarqube01.ho.mpgps.co/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
location / {
   proxy_pass http://10.200.249.24:9000;
   proxy_set_header X-Forwarded-For $remote_addr;
       proxy_set_header X-Forwarded-Proto https;

}
}
##
# Basic Settings
##
sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
# server_tokens off;

server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##

gzip on;

# gzip_vary on;
# gzip_proxied any;
# gzip_comp_level 6;
# gzip_buffers 16 8k;
# gzip_http_version 1.1;
# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

##
# Virtual Host Configs
##

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*.*;



server {
if ($host = sonarqube01.ho.mpgps.co) {
    return 301 https://$host$request_uri;
} # managed by Certbot


server_name sonarqube01.ho.mpgps.co;
listen 9090;
return 404; # managed by Certbot

}}

#mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

# auth_http localhost/auth.php;

# pop3_capabilities “TOP” “USER”;

# imap_capabilities “IMAP4rev1” “UIDPLUS”;

server {

listen localhost:110;

protocol pop3;

proxy on;

}

server {

listen localhost:143;

protocol imap;

proxy on;

}

#}

above is my nginx config but still sonarqube doesnt respond to 443.

sorry its working now thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.