In Jenkins Free style Job

New] $ /var/lib/jenkins/tools/hudson.tasks.Maven_MavenInstallation/mymaven3/bin/mvn -f /var/lib/jenkins/workspace/New/Java/tta-admin mvn clean install -U org.sonarsource.scanner.maven:sonar-maven-plugin:3.7.0:sonar
[INFO] Scanning for projects…
Downloading from central:
[WARNING] The POM for org.sonarsource.scanner.maven:sonar-maven-plugin:jar:3.7.0 is missing, no dependency information available
Downloading from central:
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.269 s
[INFO] Finished at: 2021-09-22T11:56:58+05:30
[INFO] ------------------------------------------------------------------------
[ERROR] Plugin org.sonarsource.scanner.maven:sonar-maven-plugin:3.7.0 or one of its dependencies could not be resolved: Could not find artifact org.sonarsource.scanner.maven:sonar-maven-plugin:jar:3.7.0 in central (Central Repository:) → [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] PluginResolutionException - Apache Maven - Apache Software Foundation
Build step ‘Invoke top-level Maven targets’ marked build as failure
WARN: Unable to locate ‘report-task.txt’ in the workspace. Did the SonarScanner succeed?
Posting build status of FAILED to ATCSBitbucket for commit id [c082ae17a7627ae9bec626746c3708a6b5f61b45] and ref ‘null’
Finished: FAILURE

using this pom


Hi @Bijay,

You may need to try to change your POM.xml like described here.

Best regards,

tried still getting the same error .