Illegal reflective access by com.sun.mail.util.SocketFetcher

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)

  • Developer Edition Version 9.7.1 (build 62043)

  • how is SonarQube deployed: zip, Docker, Helm
    Through Helm

  • what are you trying to achieve
    implement sendgrid as my mail server

  • what have you tried so far to achieve this
    placing all the right sendgrid settings in the general settings tab en tried a “Send test mail”
    The error I get in the gui is:
    Configuration invalid: please double check SMTP host, port, login and password.

The error in the sonarqube pod log is:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.sun.mail.util.SocketFetcher (file:/opt/sonarqube/lib/sonar-application- to method
WARNING: Please consider reporting this to the maintainers of com.sun.mail.util.SocketFetcher
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

settings implemeted are:

smtp host:
smtp port: 465
smtp userid: apikey
smtp password: xxxxxxxxxxxxxxxxx ( stands for sendgrid key )
secure connection: ssl

Please advice.


Those are warnings, not errors. Are there any errors in your server logs? Are there any errors on the SendGrind side?

:warning: Also, make sure you upgrade to SonarQube v9.9 LTS soon, not only to benefit from our Best LTS Ever™, but because soon we will systematically ask users to upgrade when they ask questions about earlier versions of SonarQube, which are now considered unsupported. :smiley:


Hello Ann,

We we are planning to upgrade to the 9.9 LTS version, but for now, we use one of the latest versions of SonarQube,( 9.7.1 ) so it won’t be a great difference to the 9.9 LTS version.
I would like to have the mail function active before migrating to the 9.9 version to get the proper report which wil be send when upgrading to a newer version. I share this info with some developers.
The message I get in the gui ( Configuration invalid: please double check SMTP host, port, login and password ) is not found in any logfile!?
I want to troubleshoot why it thinks the settings are wrong.
I doubble checked the settings, and they are the rights ones for sendgrid.


Any errors on the SendGrind side? Anything “helpful” on the network between SonarQube and SendGrind that you should talk to your network folks about?


Hello Ann,
One of my colleagues found why I got the error.
He could not find any logging pointing the error message in de gui.
But he saw that the reply address was of a not accepted domain in our openshift cluster.
I changed the reply address and now the mail function is working fine.

It remains strange that nothing can be found in the sonarqube logging about the error.

Thanks for your reply’s.

This issue can be closed.