HTML rule configuration in SonarLint for VSCode


I’ve configured SonarLint plugin in VSCode
However I do not see anything in “Problems” tab
“Output” does show Logs, but it always says “Found 0 issues” even if I’ve configured a rule for HTML files “to track copyright headers”
Could you please help to resolve this?

Following are the details:
VSCode version = 1.59.1
Sonarlint version = 2.1.2

"sonarlint.rules": {
        "Web:HeaderCheck": {
            "level": "on",
            "ruleParameters": {
                "headerFormat": "-CONFIDENTIAL-\nType: Source Code\n\nCopyright \\([cC]\\) 20[0-9]{2}, 20[0-9]{2},",
                "isRegularExpression": true
    "sonarlint.output.showVerboseLogs": true,
    "sonarlint.output.showAnalyzerLogs": true,
    "sonarlint.testFilePattern": "{**/src/**}",
    "sonarlint.pathToNodeExecutable": "C:\\\\Program Files\\\\nodejs\\\\node.exe",
    "": "C:\\\\Program Files\\\\Java\\\\jdk1.8.0_301"

Hello @manojkatarip!

Welcome to the community and thanks for your question!
Did you configured connection to SonarQube or SonarCloud and project binding or you use SonarLint without connection? If you have bindings it could be that quality profile on server overrides local settings.

Thank you @Kirill_Knize for the reply

I’m using SonarLint without connection as of now

In config you provided I can see the rule Web:HeaderCheck and it’s file level rule. Currently in VSCode we don’t have a way to report rules for whole file, so this rule will not be reported. If other rules you have problem with also file level rules - it may explain your situation.
If they are not - please provide code sample to reproduce the problem.