How to Debug "Analysis report XXXXX is missing in databse"?

Version info:
Sonarqube Version 7.9.2
Postgresql cluster Version 10.11
Scanner Version Maven-sonar-Plugin 3.6.0

I tried to scan my project and it successfully committed task to my sonarqube server.
But the task failed after 188ms,and,i can only get error messeage “Analysis report XXXXX is missing in database”.

I try to find some information from my database,and i get some information in table ce_activity,but i cant get something useful.
So,What can i do if i want to find out what’s wrong with my server? I have no idea how to debug that.Please give me some help

Some information about my database:
i have a pgsql cluster with 3 nodes on 3 different servers.And,I use pgpool-II to achieve load balance. Pgsql cluser is running in replication mode and pgpool-II is running in master-slave mode.I only turn on the native replication.

Looks like you might have several SonarQube instances connected to the same DB.

Thanks for your reply.
I try to change my pg cluster from asynchronous to synchronous,and this problem was solved.
But,i have another problem.

Here is log information by sonar server:

Log Infomation:

org.sonar.ce.task.projectanalysis.component.VisitException: Visit of Component {key=NRCS_nrcs-busi-cps_feature_58646,uuid=AWzxB8c2yZooBLmDKKro,type=PROJECT} failed
at org.sonar.ce.task.projectanalysis.component.VisitException.rethrowOrWrap(
at org.sonar.ce.task.projectanalysis.component.DepthTraversalTypeAwareCrawler.visit(
at org.sonar.ce.task.projectanalysis.step.PersistAnalysisStep.execute(
at org.sonar.ce.task.step.ComputationStepExecutor.executeStep(
at org.sonar.ce.task.step.ComputationStepExecutor.executeSteps(
at org.sonar.ce.task.step.ComputationStepExecutor.execute(
at org.sonar.ce.task.projectanalysis.taskprocessor.ReportTaskProcessor.process(
at org.sonar.ce.taskprocessor.CeWorkerImpl$ExecuteTask.executeTask(
at org.sonar.ce.taskprocessor.CeWorkerImpl$
at org.sonar.ce.taskprocessor.CeWorkerImpl.findAndProcessTask(
at org.sonar.ce.taskprocessor.CeWorkerImpl$TrackRunningState.get(
at java.base/
at java.base/java.util.concurrent.Executors$
at java.base/
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/
Caused by: org.apache.ibatis.exceptions.PersistenceException:

Error updatin

Some try:

I dont know how to fix it.It occurs sometimes.I try to use single database,not cluster.But the problem is still there.Any ideas?


For a new question, please open a new thread. And please include the entire stacktrace.


Thanks for you reply.I will follow your advise.Thank you again.