Got error and issues not loading after connecting to sonarlint

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension): 10.2
  • how is SonarQube deployed: zip, Docker, Helm - Docker
  • what are you trying to achieve - Connected to SonarLint, but after some time SonarQube issues are not loading & showing error, also found elastic search is down in the settings.

what have you tried so far to achieve this: Restarted the sonarqube server, but we don’t want this to be repeated again.

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)! “An error has occurred please contact your Administrator”

What do the logs say?

1 Like

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) 10.2
  • how is SonarQube deployed: Docker on EC2
  • what are you trying to achieve: Keep the sonarqube stable
  • what have you tried so far to achieve this: Restarting docker container

es.log
2023.12.06 12:46:51 ERROR web[o.s.s.m.ElasticSearchMetricTask] Failed to query ES status
org.sonar.server.es.ElasticsearchException: Fail to execute es requestES cluster health request
at org.sonar.server.es.EsClient.execute(EsClient.java:336)
at org.sonar.server.es.EsClient.clusterHealth(EsClient.java:210)
at org.sonar.server.monitoring.ElasticSearchMetricTask.updateElasticSearchHealthStatus(ElasticSearchMetricTask.java:56)
at org.sonar.server.monitoring.ElasticSearchMetricTask.run(ElasticSearchMetricTask.java:50)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.base/java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Request cannot be executed; I/O reactor status: STOPPED
at org.elasticsearch.client.RestClient.extractAndWrapCause(RestClient.java:940)
at org.elasticsearch.client.RestClient.performRequest(RestClient.java:3

web.log

2023.12.06 03:20:12 WARN es[o.e.c.c.ClusterBootstrapService] this node is locked into cluster UUID [1KruoYmxSX6hlX8JDqo6lQ] but [cluster.initial_master_nodes] is set to [sonarqube]; remove this setting to avoid possible data loss caused by subsequent cluster bootstrap attempts; for further information see Important Elasticsearch configuration | Elasticsearch Guide [8.7] | Elastic

I would suggest cleaning your Elasticsearch indexes and rebuilding them.

1 Like

Thanks, I will look into it

We have done that many times. Still facing similar issues when a developer connects to it