GitLab CI/CD unable to locally verify the issuer's authority after certificate update


I am using SonarQube version behind a proxy server. I updated the certificates used for the https connection because they expired.

Accessing the SonarQube web UI from the browser works after the update of the certificates without any issues.

Accessing the SonarQube from my GitLab CI/CD pipeline does not work anymore after the update of the certificates.

If the command

wget -nv https://.../cpp/

is executed within the pipeline, the following error is shown:

ERROR: cannot verify's certificate, issued by ‘CN=...O=...,C=...’:
  Unable to locally verify the issuer's authority.
To connect to insecurely, use `--no-check-certificate'.``` 

I updated the certificates via

sudo apt-get update ca-certificate

but it doesn’t solve the issue.

What’s missing for the GitLab CI/CD pipeline? Why is the error shown?


Welcome to the community!

Does this seem relevant?


It doesn’t help.

Even on standard Ubuntu the command wget… fails with the same error.

The issue was in the meanwhile solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.