Getting resource not found error on sonarqube version 8.9.9

Hi Team,

Recently we upgraded to sonarqube 8.9.9 developer edition but when we tried to publish results currently Jenkins build says resource not found and due to this some files are not being covered - below is the error - could you please check?

12:35:55 11:35:54.369 [INFO] [org.sonarqube.gradle.SonarQubeTask] Both 'sonar.groovy.jacoco.reportPath' and 'sonar.coverage.jacoco.xmlReportPaths' were set. 'sonar.groovy.jacoco.reportPath' is deprecated therefore, only 'sonar.coverage.jacoco.xmlReportPaths' will be taken into account. Please check that the JaCoCo plugin is installed on your SonarQube Instance.

and also sonarqube task says file not found error:

> Task :sonarqube **18:09:59** CodeNarc completed: (p1=0; p2=0; p3=0) 16ms **18:09:59** Metric 'test_success_density' is an internal metric computed by SonarQube. Provided value is ignored. **18:09:59** Resource not found: **18:09:59** Resource not found: **18:09:59** File not found: com/squaretrade/cappsbpm/service/ **18:09:59** File not found: com/squaretrade/cappsbpm/exception/ **18:09:59** File not found: com/squaretrade/cappsbpm/consumer/ **18:09:59** File not found: com/squaretrade/cappsbpm/config/ **18:09:59** File not found: com/squaretrade/cappsbpm/featuretoggle/

Please advise!

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) - 8.9.9 Developer edition
  • what are you trying to achieve - trying to publish coverage/unit test results
  • what have you tried so far to achieve this - Tried to install plugin’s required but it didn’t help

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!


It’s not clear to me what the problem is. The log lines you’ve shown look like warnings. The first one is basically about a duplicate setting being ignored. Fine, the first one will be used.

At a guess, the second one reports that your CodeNarc report cites file paths that don’t match those seen by your analysis.


Hi Ann,

First one says to check jacoco plugin installed on new sonarqube version 8.9.9

and second one error - we are getting mismatch in coverage results with new sonarqube version and coverage results are here -

apple-claim - [77.3%] code coverage ( Old sonarqube)
apple-claim - [85.5%] code coverage ( new sonarqube)

grid-api - [52.3%] code coverage failed (old sonarqube)
grid-api - [80.1%] code coverage passed (new sonarqube)

mismatch on the code coverage results btw old (version 7.1) and new sonarqube (developer edition 8.9.9) - could you please help to figure out?


We try to keep it to one topic per thread. Otherwise it gets messy, fast. There are two topics in your initial one and your reply appears to introduce a third.

JaCoCo coverage report import is an out-of-the-box feature. That warning message shouldn’t be directing you to make sure it’s installed. You can ignore that part of the message.