Getting error about upgrading to latest Jacoco binary version

java
coverage

(Gary Sturgeon) #1

Here’s the full error

13:06:14 [ERROR] Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin:3.5.0.1254:sonar (default-cli) on project parent: You are not using the latest JaCoCo binary format version, please consider upgrading to latest JaCoCo version. -> [Help 1]

Previously I’ve seen these as a warning message, but now it kills my build as an error. I tried setting the jacoco version to 0.8.2 in my parent pom, but it has made no difference.

Any ideas?


(Gary Sturgeon) #2

There are some builds I have that never generated the warning (no idea why) that do still work. There is no differences I can find though.

Anyone ever get this before?


(Nicolas Peru) #3

Could share a bit more of the logs ? notably where the JaCoCo report is picked up ?

Moreover : how do you generate this report ? can you share an excerpt of your project configuration regarding this ?


(Gary Sturgeon) #4

sonar.txt (50.8 KB)

pom.txt (11.7 KB)

Attached a log of the sonar portion of the build and the parent POM. The build uses the coverage profile to pick up code coverage.


(Gary Sturgeon) #5

This seems to have started when I upgrade the SonarJava plugin from 5.5 to 5.8. However when I tried to go back to 5.5 I got incompatible version errors so I guess there isn’t any going back.


(Nicolas Peru) #6

in your pom.xml I read at line 227 :

    <groupId>org.jacoco</groupId>
    <artifactId>jacoco-maven-plugin</artifactId>
   	<version>0.7.4.201502262128</version>

Please upgrade the version of JaCoCo to latest version (0.8.2)


(Gary Sturgeon) #7

Nice catch! Unfortunately I still get the same error. Attaching the full log.

log.txt (623.0 KB)


(Gary Sturgeon) #8

I have it working now! I had to delete the maven cache as well it seems.

Thanks for your assistance!