Files indexed but json file empty

Must-share information (formatted with Markdown):
Sonarqube 10.2
Sonarscanner dotnet
latest buildwrapper

I’m trying to analyze GlplkSharp opensource project. When it runs it says it indexed 15 files. But when it completes it throws an error saying the json file is empty. I read through other posts but can’t figure out what the issue is. I did see a post where they said the indexed files didn’t match the build files. I’m not sure how that would happen in this case. It builds just fine and there are only the 15 files. I can’t share any of the build, but I can add the buildwrapper log, and json file that were output. I tried with the cli scanner and got the same result.

commands used:

%sonarScannerMsBuildExePath% begin /k:"GlpkSharp_1.0_1" /"XXXX" /d:sonar.token="XXXX" /"%buildWrapperOutput%" /d:sonar.cs.analyzer.projectOutPaths="%projectDirectory%" /d:sonar.vbnet.analyzer.projectOutPaths="%projectDirectory%" /d:sonar.verbose=true

%sonarScannerBuildWrapperWinX86_X64Exe% --out-dir build_wrapper_output_directory %msBuildExePath% GlpkSharp.sln /t:Rebuild /p:Configuration=Debug /p:Platform=x64 /nodeReuse:False

%sonarScannerMsBuildExePath% end /d:sonar.token="XXXX"

This works fine for other c++ projects like slimDX, not sure why its not working for this project.
build-wrapper.log (37.4 KB)

build-wrapper-dump.json (23.2 KB)

Hey there.

If this project is open-source, can you share a link to the public repo?

Of course.

Thank you.

Thanks. It looks like this project makes heavy use of /clr, which is not supported. You can read more about this here:

Thank you so much for the information. I appreciate the help.