Failed to upload report - HTTP code 413

Hi All,

When I trigger Sql code analysis through Jenkins I’m getting Failed to upload report - HTTP code 413 error and if the upload report is less than 20 MB it is working fine but my complete report is 45 MB.

I have tried below solutions till seeing the issue.
The IIS setting uploadReadAheadSize to its maximum allowed value.

Enable “Negotiate Client Certificate” for the certificate bindings

Set maxAllowedContentLength to its maximum value 4294967295

I changed maxRequestEntityAllowed to max(4gb)

Also Added sonar.web.accessLogs.enable=true in where I can see the access.logs?

Could anyone please help me on this I’m contacting on this for longtime.

INFO: Analysis report generated in 5995ms, dir size=198 MB
INFO: Analysis report compressed in 13797ms, zip size=38 MB
INFO: ------------------------------------------------------------------------
INFO: ------------------------------------------------------------------------
INFO: Total time: 3:32:37.629s
INFO: Final Memory: 7M/34M
INFO: ------------------------------------------------------------------------
ERROR: Error during SonarScanner execution
ERROR: Failed to upload report - HTTP code 413:

413 Request Entity Too Large

413 Request Entity Too Large

ERROR: ERROR: Re-run SonarScanner using the -X switch to enable full debug logging. WARN: Unable to locate 'report-task.txt' in the workspace. Did the SonarScanner succeeded? ERROR: SonarQube scanner exited with non-zero code: 1


As you’ve discovered, this is about your IIS settings. If you can’t tune them appropriately, then your options as I see it are to either bypass the proxy for analysis, or split your project up into multiple, smaller projects.