Failed to remotely connect to the JMX Bbean of Sonarqube SearchServer

java
sonarqube

(ken.lam) #1

My sonarqube sever version: 6.7

As per the setup in https://docs.sonarqube.org/display/SONARQUBE67/JMX+MBeans,
I added the below property into the sonar.properties file.

sonar.search.javaAdditionalOpts=-Dcom.sun.management.jmxremote=true -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=true -Dcom.sun.management.jmxremote.port=19010 -Dcom.sun.management.jmxremote.rmi.port=19011 -Dcom.sun.management.jmxremote.password.file=/opt/sonarsource/sonar/conf/jmxremote.password -Dcom.sun.management.jmxremote.access.file=/opt/sonarsource/sonar/conf/jmxremote.access

But I failed to remotely connect to it by jconsole. Please also see the screenshot below.

I can telnet to it remotely. I also tried using different ports and still failed to connect it by jconsole. However, I can remotely connect to ComputeEngine and WebServer JMX Mbean. Do you guys have any idea? I have been stuck in it for a while. Please help.


(G Ann Campbell) #2

Hi,

Thanks for pointing this out. As it turns out, you’re not doing anything wrong; we failed to update the documentation. When we upgraded to ES 5 in the LTS, we moved to a version that no longer allows that kind of exposure, so we dropped the bean on our side. I’ve updated the documentation.

Sorry for the confusion, and thanks again!

 
Ann


(ken.lam) #3

Dear Ann,

Thank for your reply.
FYI, I found a workaround recently. jconsole can connect to it if the jmx remote authenication is disabled.
Please see the following property in sonar.properties that I have set:

sonar.search.javaAdditionalOpts=-Dcom.sun.management.jmxremote=true -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.port=10643 -Dcom.sun.management.jmxremote.rmi.port=10644 

Ken