Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin, Status returned 404

SonarQube Version: 6.7.6 (build 38781)
sonar-maven-plugin: or

When I run command: mvn org.sonarsource.scanner.maven:sonar-maven-plugin:
I got error below:

[ERROR] Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin: (default-cli) on project wireless: Unable to execute SonarQube:
Fail to get bootstrap index from server: Status returned by url [] is not valid: [404] -> [Help 1]

I visit url “” in my browser, it return : sonar-scanner-engine-shaded-6.7.6.jar|78f8863715234a6d19ee37780ea4a059

But When I run command :mvn org.sonarsource.scanner.maven:sonar-maven-plugin:3.2:sonar ,It’s work fine . I need use sonar-maven-plugin new version to analyze kotlin’s coverage, What did I do wrong?

Can you please include the output of mvn sonar:sonar -X ?

Do you have access to the logs on the server? Can you monitor if some exceptions show up at server side at around the time when you run the analysis?

@felix1982 Is still an issue?

3 posts were split to a new topic: Fail to get bootstrap index from server:

Apologies for the necro but i had a similar issue and this was my answer

I respect I had a different error code but I have noticed that the error code varies depending on what version of sonar-maven-plugin I use.