Failed to connect to node 9001

I’m upgrading SonarQube from 7.1 to 7.9.2 using this tutorial and everything goes well up until I run SonarQube, where it runs but isn’t showing up. The only error I get in the logs is below.

It says it cannot connect to the node, but the final line says it is connected to the elastic search node?


2020.01.23 12:09:06 DEBUG app[][o.e.c.t.TransportClientNodesService] failed to connect to node [{#transport#-1}{xWfa6Tf6RzKU9B6Or7QcSQ}{}{}], ignoring...
org.elasticsearch.transport.ConnectTransportException: [][] connect_exception
        at org.elasticsearch.transport.TcpTransport$ChannelsConnectedListener.onFailure(
        at org.elasticsearch.action.ActionListener.lambda$toBiConsumer$2(
        at org.elasticsearch.common.concurrent.CompletableContext.lambda$addListener$0(
        at java.base/java.util.concurrent.CompletableFuture.uniWhenComplete(
        at java.base/java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(
        at java.base/java.util.concurrent.CompletableFuture.postComplete(
        at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(
        at org.elasticsearch.common.concurrent.CompletableContext.completeExceptionally(
        at org.elasticsearch.transport.netty4.Netty4TcpChannel.lambda$new$1(
        at io.netty.util.concurrent.DefaultPromise.notifyListener0(
        at io.netty.util.concurrent.DefaultPromise.notifyListeners0(
        at io.netty.util.concurrent.DefaultPromise.notifyListenersNow(
        at io.netty.util.concurrent.DefaultPromise.notifyListeners(
        at io.netty.util.concurrent.DefaultPromise.tryFailure(
        at io.netty.util.concurrent.SingleThreadEventExecutor$
        at java.base/
Caused by:$AnnotatedConnectException: Connection refused: /
        at java.base/ Method)
        at java.base/
        ... 6 common frames omitted
Caused by: Connection refused
        ... 10 common frames omitted
2020.01.23 12:09:06 DEBUG app[][o.s.a.e.EsConnectorImpl] Connected to Elasticsearch node: []


2020.01.23 12:09:49 INFO  app[][o.s.a.SchedulerImpl] Process[ce] is up
2020.01.23 12:09:49 INFO  app[][o.s.a.SchedulerImpl] SonarQube is up

At the end of sonar.log it says SonarQube is running, and if i run status, that confirms SonarQube is running, but nothing is at localhost:9000.

I’m running Linux and my versions are:
SonarQube 7.9.2
PostgreSQL 10.11
Open JDK 11.0.6


That error is at the DEBUG level because it’s not directly relevant. What do your other logs say?

Also, that tutorial suggests you edit your SQ port to 80. Did you do that? And if so, is anything running on localhost/localhost:80?


Hi Ann,

thanks for the reply. But no worries, it was a network issue on my end.


I am seeing the same issue in my server. What was the network problem at your end?


I was trying to view it on the wrong host, so just my error rather than anything else. Probably not much help to you.

A post was split to a new topic: Startup error on docker