Fail to extract report from database

I don’t know what the problem caused. Just since today SonarQube don’t analyze any already created project (i don’t tested of recreating project).

  • SonarQube is running under Ubuntu 20.04.3 (not in Docker).
  • SonarScanner running in Docker container (triggered via GitLab CI).
  • SonarQube and SonarScanner runs in VMs, but under one host.

Used versions:

  • SonarQube LTS 8.9.7.52159
  • SonarScanner 4.7.0.2747

Installed plugins:

What i tried do:

  • Restart SonarQube, PostgreSQL, GitLab Runner host fully
  • Update SonarQube (previously installed version, where problem started - 8.9.6.50800)

All starts now finishes with error:

java.lang.IllegalStateException: Fail to extract report AX_UtEZ41h8m7up_9Kch from database
	at org.sonar.ce.task.projectanalysis.step.ExtractReportStep.execute(ExtractReportStep.java:72)
	at org.sonar.ce.task.step.ComputationStepExecutor.executeStep(ComputationStepExecutor.java:81)
	at org.sonar.ce.task.step.ComputationStepExecutor.executeSteps(ComputationStepExecutor.java:72)
	at org.sonar.ce.task.step.ComputationStepExecutor.execute(ComputationStepExecutor.java:59)
	at org.sonar.ce.task.projectanalysis.taskprocessor.ReportTaskProcessor.process(ReportTaskProcessor.java:81)
	at org.sonar.ce.taskprocessor.CeWorkerImpl$ExecuteTask.executeTask(CeWorkerImpl.java:212)
	at org.sonar.ce.taskprocessor.CeWorkerImpl$ExecuteTask.run(CeWorkerImpl.java:194)
	at org.sonar.ce.taskprocessor.CeWorkerImpl.findAndProcessTask(CeWorkerImpl.java:160)
	at org.sonar.ce.taskprocessor.CeWorkerImpl$TrackRunningState.get(CeWorkerImpl.java:135)
	at org.sonar.ce.taskprocessor.CeWorkerImpl.call(CeWorkerImpl.java:87)
	at org.sonar.ce.taskprocessor.CeWorkerImpl.call(CeWorkerImpl.java:53)
	at com.google.common.util.concurrent.TrustedListenableFutureTask$TrustedFutureInterruptibleTask.runInterruptibly(TrustedListenableFutureTask.java:125)
	at com.google.common.util.concurrent.InterruptibleTask.run(InterruptibleTask.java:69)
	at com.google.common.util.concurrent.TrustedListenableFutureTask.run(TrustedListenableFutureTask.java:78)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:829)
Caused by: java.util.zip.ZipException: invalid entry CRC (expected 0x31cad256 but got 0x7dadc14)
	at java.base/java.util.zip.ZipInputStream.readEnd(ZipInputStream.java:410)
	at java.base/java.util.zip.ZipInputStream.read(ZipInputStream.java:199)
	at java.base/java.io.FilterInputStream.read(FilterInputStream.java:107)
	at org.sonar.api.internal.apachecommons.io.IOUtils.copyLarge(IOUtils.java:1158)
	at org.sonar.api.internal.apachecommons.io.IOUtils.copy(IOUtils.java:878)
	at org.sonar.api.internal.apachecommons.io.IOUtils.copyLarge(IOUtils.java:1135)
	at org.sonar.api.internal.apachecommons.io.IOUtils.copy(IOUtils.java:854)
	at org.sonar.api.utils.ZipUtils.copy(ZipUtils.java:168)
	at org.sonar.api.utils.ZipUtils.unzipEntry(ZipUtils.java:110)
	at org.sonar.api.utils.ZipUtils.unzip(ZipUtils.java:94)
	at org.sonar.api.utils.ZipUtils.unzip(ZipUtils.java:63)
	at org.sonar.ce.task.projectanalysis.step.ExtractReportStep.execute(ExtractReportStep.java:70)
	... 19 more

I found topic with a similar problem, but solution is not found.

Hi,

The Community Branch Plugin is not supported in this community. Further, we have reports of it causing trouble with people’s databases. We cannot help you with this problem.

 
Ann

Further, we have reports of it causing trouble with people’s databases.

Can I see this reports?
This extension is installed more than half-year, and before today, i don’t have any issues.

I continue investigate issue today when officials isn’t interested and just says “You’re using plugin what causes troubles with databases”.

GitLab Runner runs a SonarScanner in Docker with official Docker image. Our .gitlab-ci.yml:

sonarqube-check:
    image:
        name: sonarsource/sonar-scanner-cli:latest
        entrypoint: [""]
    variables:
        SONAR_USER_HOME: "${CI_PROJECT_DIR}/.sonar"
        SONAR_TOKEN: "${SONAR_TOKEN}"
        SONAR_HOST_URL: "${SONAR_HOST}"
        GIT_DEPTH: "0"
    cache:
        key: "${CI_JOB_NAME}"
        paths:
            - .sonar/cache
    script: 
        - sonar-scanner
    allow_failure: true

I’me attempted a try manual run SonarScanner on my PC (Windows) and was amazed: they runned without any issues. Any suggestions? Maybe try run Scanner in own build SonarScanner image or use oldest version?

On future, do not use :latest. Never. :man_facepalming:
I checked availables tags on Docker Hub and noticed that the image was updated just before the problems started. I specified tag 4.6 and all works normally.

Looks like image broken. Idk, why.
Thanks for everyone who tried help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hey @CrazyHackGUT

See this update here: