Eslint-bridge is unresponsive when analyzing PHP and JS project

Hey Guys,

None of the above solution worked for me.
Running the code analysis task in the pipeline on gitLab for some time now I encounter this error:

ERROR: eslint-bridge Node.js process is unresponsive. This is most likely caused by process running out of memory. Consider setting sonar.javascript.node.maxspace to higher value (e.g. 4096).
ERROR: Failure during analysis, Node.js command to start eslint-bridge was: node --max-old-space-size=4096 /builds/efahrer/application/.scannerwork/.sonartmp/eslint-bridge-bundle/package/bin/server 38747 /builds/efahrer/application/.scannerwork false false /builds/efahrer/application/.scannerwork/.sonartmp/eslint-bridge-bundle/package/custom-rules13118973454471921980/package

I have already tried changing the sonar.javascript.node.maxspace property (up to 16GB) and I have tried implementing sonar.javascript.allowTsParserJsFiles=false but in both cases without success.
Does anyone know how I could solve the problem?
this is the entire exception log
sonarqube log.txt (6.8 KB)

  • how is SonarQube deployed: Docker
  • sonarqube:9.9-developer (
  • sonarsource/sonar-scanner-cli:latest (
  • Java 11.0.20 Alpine (64-bit)
  • Linux 5.15.0-1036-aws amd64

Hey there.

Can you provide your Gitlab CI YAML file?

I am only attaching the part concerning the analysis of the code. however, nothing exaggerated (1.2 KB)