Error in the SonarQube Dev Edition integration with Bitbucket Cloud

Version: Developer Edition Version 9.4 (build 54424)
Achieve: SonarQube and Bitbucket Cloud integration
After configuration, I am receiving the follow error message:

Confirm access to your account

Invalid redirect_uri
This integration is misconfigured. Contact the vendor for assistance.


We have a slight suspicion that the callback URL is missing.
Would you please help me with issue?

Ortiz Jesus

Hi Ortiz,

It’s not quite clear to me. Are you trying to configure delegated authentication?

If so, can you temporarily turn your server logging up to TRACE level and re-creating the error. You’re likely to get something interesting in $SONARQUBE-HOME/logs/web.log.


Good afternoon,

I am trying to integrate SonarQube with Bamboo Cloud as Documented:

The goal here is integrating the sonar analysis from Bitbucket when a Pull request has been created.

But I am receiving the error: Invalid redirect_uri This integration is misconfigured. Contact the vendor for assistance.

Related to the follow configuration in Administrator → DevOps Integration Platform → Bitbucket

Would you please help me to get the information using my current configuration:


  • What is and where must set: sonar.core.serverBaseURL = ?
  • Workspace ID –
    The workspace ID is part of your bitbucket cloud URL{WORKSPACE-ID}/{repository-slug} = ?
  • CallBack = ?

My Data:
Repository: Log in with Atlassian account

I set the follow information:

  • OAuth Key – I have this.
  • OAuth Secret – I have this.

If you need a call to review my SonarQube Server configuration or my OAuth configuration I am available any time, my email is:

Ortiz Jesus


Thanks for the clarifications.

As described in the docs, the callback URL is something you configure in your Bitbucket Cloud workspace settings.

The sonar.core.serverBaseURL is essentially the setting that tells SonarQube what it’s own URL is. The server then uses it in links & emails &etc. You’ll find it in Administration → General, a little more than half-way down the page.

Also from the docs:

  • Callback URL – your SonarQube instance URL.

(I.e. the same value you filed in on the SonarQube side for the sonar.core.serverBaseURL.)


Hi Ann,

Would you please send 2 examples for CallBack configration and sonar.core.serverBaseURL?

Where I must configure the sonar.core.serverBaseURL, please send instructiond and example.

NOTE: my current SoanrQube Server is:

Ortiz, Jesus


No need. You’ve just sent your own example:

As I said, it’s configured


Hi Ann,

After configuration, I have received the follow:

How can fix it?

In advance, thank you.

Ortiz Jesus


This looks like an authentication problem and it should be unrelated to configuring sonar.core.serverBaseURL. You need to see what your server logs say. You may need to tune the server log level up to DEBUG to get full details. You can do that in $SONARQUBE-HOME/ (You’ll need to restart for the changes to take effect.) You’ll want to tune it back to INFO when you’ve got the logging you need; those logs get big fast at DEBUG level.